I suggest you ...

Continue supporting .NET 4.0 projects

Microsoft has ended support for .NET 4, 4.5 and 4.5.1 on January 12th:
https://blogs.msdn.microsoft.com/dotnet/2015/12/09/support-ending-for-the-net-framework-4-4-5-and-4-5-1/

We've started seeing some of our 3rd Party NuGet dependencies stop providing .NET 4.0 builds which is forcing us to reference old packages and prevents us from being able to access newer features.

As a result we plan to follow .NET recommendation and stop providing .NET 4.0 builds for all releases after August 1st, 2016.

If you absolutely need .NET 4.0 builds beyond this date please leave a comment on this request describing your use-case as well as the expected date before you will be able to upgrade to .NET 4.5.

.NET 4.0 builds will continue to be available for releases before August 1st but will no longer be providing any .NET 4.0 builds for any new releases after. We'll create v4 branches in all our repos just before we upgrade projects to .NET 4.5 so you can add fixes or create custom .NET 4.0 builds if needed, but we wont be maintaining the legacy v4 branches after August 1.

5 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    AdminDemis J Bellot (Developer, ServiceStack) shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

    0 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      Signed in as (Sign out)
      Submitting...

      Feedback and Knowledge Base